Interface Introduction

When you open APSplit DE, you will see a window with two tabs and three menu items. These tabs and menus, along with the settings dialog box, are described below.

Tabs

The tabs, along with the Settings dialog box, which is accessible from the tabs, comprise the main work area in APSplit DE.

Single File tab

Use the Single File tab to split one file at a time. You can split a single file by single pages, page range, file size, first-level bookmarks, even pages, or odd pages.

The fields on the Single File tab are described in the following topics. Unless noted otherwise, the general fields apply to all types of single-file split operations and are always visible. The remaining fields are only available for certain types of split operations.

General fields

Split Options — Lists all of the methods for splitting a single file:

Split by Page — Each page in the original file becomes a new file.

Split by Size — The original file is split into one or more new files based on maximum output file size and page count.

Split by Page Range — A single page range or consecutive page ranges of the same length are extracted to one or more new files.

Split by Advanced Page Range — Page ranges of any size and from any location are extracted to new files.

Split by Bookmarks — Each first-level bookmark section becomes a new file.

Split out Even Pages — All of the even pages are extracted to a new file.

Split out Odd Pages — All of the odd pages are extracted to a new file.

Input PDF File — The PDF document you want to split.

Browse button — Takes you to a dialog box, where you can select an input PDF file.

Output Folder — The directory in which you want the results of the split to be placed.

Note: The path name must end with a slash, as shown in the following example:

Example: C:\Appligent\ApSplit DE\Output\

Browse button — Takes you to a dialog box, where you can select an output directory.

Output FileName (available for all split options except Page Range).

  • For Even and Odd Page splits, this field is required and is the name of the output file in which to place the extracted pages.

  • For Page, Size and Bookmarks  this field is optional and is the file name to be used as a base in forming the output file name(s). For example, if you type OutputFile.pdf, the output files would be named OutputFile.nnnnnn.pdf, where nnnnnn is the number of the first page in the extracted section (for example, OutputFile.000001.pdf, OutputFile.000007.pdf, OutputFile.000012.pdf, and so on). If you do not enter anything, the input file name is used as the base output file name.

Settings button — Takes you to the Settings dialog box, where you can enter an Owner password for the input file, if needed; output file save preferences; and logging options.

Split button — Executes the split operation.

Split by Page Range fields

Split by Range — Lets you specify the details of a split by page range:

Start Page — The first page number in the range to be extracted.

End Page — The last page number in the range to be extracted.

Repeat — The number of times to extract the number of pages indicated by the Start Page and End Page values.

Example: A Start Page of 2, an End Page of 6, and a Repeat of 10 will create 10 5-page files. The first contains pages 2–6 from the original file, the second contains pages 7–11, the third contains pages 12–16, and so on for a total of 10 extractions, up to the maximum number of pages in the original file.

Split by Size fields

Split by Size — Lets you specify the details of a split by file size:

KiloBytes — The maximum size, in kilobytes (KB), of each output file to be extracted. The maximum file size is limited by the page count (see Pages below).

Pages — The maximum number of pages to be extracted to each output file. The maximum page count takes precedence if it is reached before the maximum file size.

Example: Assume a maximum file size of 500 KB and a maximum page count of 20. Even if 35 pages are required to reach a file size of 500 KB, only 20 pages are extracted.

Note: APSplit DE does not break pages into fractional components; the smallest number of pages that can be extracted to an output file is one. Therefore, if your document has a page that is larger than the number of kilobytes you specify, it will be extracted as a single page in spite of the size restriction.

Split by Advanced Page Range fields

Table — The list of each page range to be extracted, plus the name of the file in which to place the contents of the extraction.

Show Full Path checkbox — Check this box to view the full paths of file names in the table.

Split List Item — Use to populate the above table:

Start Page — The first page number in the range to be extracted.

End Page — The last page number in the range to be extracted.

Outfile Name — The name of the output file to which you want to extract the page range designated by the Start Page and End Page fields. (The directory of the file is specified in the Output Folder field.)  You can select different output directories for each page range you choose to split.

Add Item button — Adds the entries in the Start Page, End Page, and Outfile Name fields to the table.

Change Item button — Updates the selected table item, associated Output Folder, or both based on changes you make to any of the following fields: Output Folder, Start Page, End Page, and Outfile Name.

Remove Item button — Removes the selected item from the table.

Open List button — Opens the Select a List File dialog box, from which you can select a previously saved list file to apply to your file extraction. (See Save List button.)

Save List button — Opens the Save List File dialog box, where you can save the page range list in the table, plus the directory associated with each page range, to a list file. (The file must be in TXT format.) You will not be able to split your PDF document until the list has been saved.

Multiple Files tab

Use the Multiple Files tab to split more than one file at a time. You can split multliple files by single pages, page range, file size, or first-level bookmarks.

The fields on the Multiple Files tab are described in the following topics. The general fields apply to all types of multiple-file split operations and are always visible. The remaining fields are only available for certain types of split operations.

General fields

Split Options — Lists all of the methods for splitting more than one file at a time:

Split by Page — Each page in the original files becomes a new file.

Split by Size — The original files are split into one or more new files based on maximum output file size and page count.

Split by Page Range — A single page range or consecutive page ranges of the same length are extracted to one or more new files.

Split by Bookmarks — Each first-level bookmark section becomes a new file.

File List section — The PDF files you want to split.

Add File button — Opens the Select a PDF file dialog box, from which you can select a file to split.

Add Folder button — Opens the Select a Folder dialog box, from which you can select a directory containing PDF files that you want to split. When you select a directory, all of the PDF files in that directory, including its subdirectories, are added to the File List section.

Remove button — Removes the selected file(s) from the  File List section.

Output Directory — The directory in which the results of the split will be placed.

Browse button — Takes you to a dialog box, where you can select an output directory.

Settings button — Takes you to the Settings dialog box, where you can enter an Owner password for the input files, if needed; output file save preferences; and logging options.

Note: All secured files that are split at the same time must have the same Owner password. If you want to split files that have different Owner passwords, group the files by password and perform a separate split operation for each group.

Split button — Executes the split operation.

Split by Page Range fields

Split by Range — Lets you specify the details of a split by page range:

Start Page — The first page number in the range to be extracted.

End Page — The last page number in the range to be extracted.

Repeat — The number of times to extract the number of pages indicated by the Start Page and End Page values.

Example: A Start Page of 2, an End Page of 6, and a Repeat of 10 create 10 5-page files. The first contains pages 2–6 from the original file, the second contains pages 7–11, the third contains pages 12–16, and so on for a total of 10 extractions, up to the maximum number of pages in the original file.

Split by Size fields

Split by Size — Lets you specify the details of a split by file size:

KiloBytes — The maximum size, in kilobytes (KB), of each output file to be extracted in a split by file size. The maximum file size is limited by the Page Count (see Pages below).

Pages — The maximum number of pages to be extracted to each output file. The maximum page count takes precedence if it is reached before the maximum file size.

Example: Assume a maximum file size of 500 KB and a maximum page count of 20. Even if 35 pages are required to reach a file size of 500 KB, only 20 pages are extracted.

Note: APSplit DE does not break pages into fractional components; the smallest number of pages that can be extracted to an output file is one. Therefore, if your document has a page that is larger than the number of kilobytes you specify, it will be extracted as a single page in spite of the size restriction.

Settings dialog box

Use the Settings dialog box to set an Owner password for the input file, if needed, output file save preferences, and logging options. The Settings dialog box contains the following fields:

Owner Password to Open File — The Owner password of a secured PDF file. The Owner password, also known as the Master password or Permissions password, is required if a PDF file you are splitting is secured. (The User password, also called the Open password, does not work with APSplit DE. You must supply the Owner password.)

Note: All secured files that are split at the same time must have the same Owner password. If you want to split files that have different Owner passwords, group the files by password and perform a separate split operation for each group.

Save Options — Lets you specify preferences to be applied when saving output files:

Retain Page Annotations — When checked, saves page annotations (also called comments) from the input files in the output. When unchecked, page annotations are not saved in the output. Annotations include notes, text, audio, stamps, form fields (Widgets), files, pencil marks, rectangles, ellipses, lines, highlights, cross outs (strikethroughs), and underlines.

Save Linearized for Fast Web View — When checked, linearizes multipage files for more efficient web delivery. When unchecked, saves files normally, without linearizing. Linearization allows individual pages to be rendered before the entire document has downloaded, so the user can start reading the document sooner.

Logging Options — Lets you specify a log file to which error and progress messages will be written. If you do not specify a log file, progress and error messages are written to the default log file, APSplitDE_log.txt.

Log File Path — A text file to which progress and error messages will be logged.

Browse button — Takes you to a dialog box, where you can enter a log file path name.

Show Log File button — Displays the current log file.

Menus

Although you won’t need the menus for most split operations, they provide some handy shortcuts for speeding up your work, as well as product and support information:

File menu

Use the File menu to save and open project files, as well as to exit the application. A project file stores the current entries on the APSplit DE tabs and Settings dialog box. If you frequently perform the same type of split operation, or use the same files or directories, you will save time by using a project file.

The File menu contains the following items:

New — Closes any existing project file and creates a new one. A new project file is created automatically when you start APSplit DE.

Open — Displays a dialog box, from which you can open an existing project file.

Save — Saves the current entries to a project file. If this is a new file, a dialog box is displayed, where you can specify a name and location for the file. A project file name must end with an .xml extension.

Save As — Displays the Save As dialog box, where you can enter a new name, location, or both for the project file. A project file name must end with an .xml extension.

Exit — Closes the APSplit DE application. If any entries have changed since the last time you saved the current project file, you will be prompted to save the changes before closing.

Edit menu

Use the Edit menu to work with information in text fields. The Edit menu contains the following items:

Cut — Removes the selected text and places it on the Clipboard.

Copy — Places a copy of the selected text on the Clipboard.

Paste — Pastes the Clipboard text at the insertion point.

Delete — Deletes the selected text.

Select All — Selects everything in the text field in which the cursor is positioned.

Help menu

Use the Help menu to enter your registration number and get information about APSplit DE. The Help menu contains the following items:

APSplit DE Help — Displays online help in a local browser window.

License — Displays a dialog box, where you can enter the product serial (registration) number or buy a product license if you do not have one.

About APSplit DE — Displays information about your copy of APSplit DE as well as provides contact information for Appligent Document Solutions.