Reviewing the Troubleshooting Checklist

The following topics describe what you can do if you do not get the results you expect when you run StampPDF DE.  This troubleshooting checklist describes common problems experienced by customers. It is the first place to look for a solution to your problem.

Did you get an error message “Unable to save  PDF file”-related error message?

There is a problem with an input file or an output file.

  • If the input file is encrypted, you must specify an Owner password. To specify the Owner password, go to the Main tab, click the Advanced Options button, enter the Owner password, and then click OK.
  • If the output file is open, you must close it.
  • If the output file is read-only, you must enable write permission.

Note: You can only specify one Owner password. Therefore, all of the encrypted files you stamp at the same time must have the same Owner password. If you want to stamp encrypted files that have different Owner passwords, perform a separate stamping operation for each Owner password.

Are all file and path names correct?

If you enter file or folder names manually, make sure to specify them correctly.

Do not include any of the following special characters in file or folder names:  \ / : * ? “ < > | ^ &

Enter the full path name, separating directories with a slash. Use a back slash (\) in Windows.

Example:  C:\Appligent\StampPDFDE\Samples\stamp_files\letterstamp.txt

When specifying the output path, include the trailing slash.

Example:  c:\Appligent\StampPDFDE\Samples\Output\

Your stamp does not appear on the PDF.

If you applied an underlaid stamp (Layer = Underlay)and it is not visible, the cause is probably one of the following:

  • The PDF document was scanned as an image file (rather than an OCR text file), and the image is obscuring the stamp.
  • The stamp is under a hidden image.
  • The printer driver and application used to generate the PDF document created a white rectangle underneath the PDF content, and the stamp is under the white rectangle.

For these types of documents, use an overlaid stamp (Layer = Overlay). To prevent obscuring the content underneath the stamp, set the Mode to Outline or Invisible, or set the Mode to Solid and decrease the Opacity.

Cleaning Up PDF Documents

Not all PDF files are created equal. The way in which a PDF document is generated makes a difference, and PDFs generated by third party tools in particular can vary in quality. PDF documents can also become corrupted.

To check how the file was created:

  • In Acrobat X, XI and DC select File > Properties… and click Description. Under Advanced, look at PDF Producer.

If the PDF Producer field is blank, consider the file suspect.

Making a Clean PDF

If you are having problems with a specific PDF, try to create “clean” version of your document. There are two ways of doing this using Adobe Acrobat. If you use other PDF manipulation software, check the documentation for functions that may be equivalent to those found in Adobe Acrobat.

Method 1: “Optimize” your PDF

  • In Acrobat X, XI and DC > File Menu > Save As > Optimized PDFo

If saving as optimized does not work, distill the document by following the steps below.

Method 2: Distilling PDF Documents

Distilling a document will remove all comments and form-fields from the PDF.  If the PDF contains these items and you wish to preserve them, you must save them before Distilling.

To save existing comments

  • In Acrobat X, XI and DC select Comments > Comments List > click the Options icon > Export All to Data File… In the Export Comments dialog box, select a name and location for the Forms Data File (.fdf), and click Save.

See the additional step below for saving form fields (if any):

Delete all comments:

  • In Acrobat X, XI and DC select all the comments in the Comments List pane and press the Delete key.

To save form fields (if any):

  • Save a copy of the original file. You will copy and paste the form fields from the original file into the new file after the distilling procedure.

Distilling the document

To distill a PDF document do the following:

  • In Acrobat X and XI select File > Save As > More Options > PostScript. Choose a name and location for the file and click Save
  • In Acrobat DC select File > Export to > PostScript.  Choose a name and location for the file and click Save
  • Open Acrobat Distiller > select File > Open..In the open PostScript File dialog, locate the PostScript file created in the previous step and click Open.

The distiller will create a new PDF file with the same name and location as the PostScript file.

Restoring comments

To restore the comments:

  • In Acrobat X and XI, select Comments > Comments List > click the Options icon > Import Data File… In the Import Comments dialog box, locate the Forms Data File (.fdf) previously saved and click Select. In the next pop-up box, click Yes. The comments are restored.
  • In Acrobat DC, select Tools > Comments > Comments List > click the Options icon > Import Data File…In the Import Comments dialog box, locate the Forms Data File (.fdf) previously saved and click Select.  In the next pop-up box, click yes.  The comments are restored.

Restoring form fields

To restore form fields:

  • Open the original PDF file that includes form fields.
  • In Acrobat X and XI select Tools > Forms > Edit Form
  • In Acrobat DC, select Tools > Prepare Form > Form fields will automatically appear
  • The form fields will appear, do a Control-A to select all the form fields
  • Open the new distilled PDF file which has no form fields
  • Do a Control-V to paste all the form fields onto the page

You may need to reposition the fields by selecting them again with the Select Object Tool and moving them to the correct position. For multi-page forms you must do this for each page separately.